Requirements for Scandit Data Capture SDK 6.25

Native Platforms

Platform

Requirements

Android

  • Android 6.0 (API level 23)

  • Java 8

  • ARMv7, ARM64, x86, x86_64

  • Camera resolution of 720p or higher is recommended

  • GPU required 1

iOS

  • iOS 13.0

  • ARM64, x86_64

  • Camera resolution of 720p or higher is recommended

  • GPU required

1

On Android hardware acceleration has to be enabled for the camera preview to work. Hardware acceleration is enabled by default since API level 14 but can potentially be turned off in the Manifest, do not do this if you use the camera.

Web Platforms

Requirements

This results in the current browser compatibility table:

Multithread / Single Thread minimum browser versions

Browser

Threads

Single thread

Chrome

68+

61+

Edge

79+

79+

Firefox

105+

105+

Opera

55+

44+

Safari

15.2+

13+

Chrome Android

89+

61+

Firefox Android

105+

105+

Opera Android

63+

46+

Safari iOS / Chrome iOS (webkit)

16.4+

14.6+

Samsung Internet

15+

7+

Webview Android

No

Yes

Framework Platforms

These platforms are based on the native platforms and therefore the requirements of native platforms apply to the framework platforms as well. Should a framework have stricter requirements (e.g. it only supports newer versions of Android/iOS) then it is explicitly stated.

Platform

Requirements

Capacitor

Cordova

Flutter

  • Flutter 3.22.0 (Dart 3.4.0)

  • Swift 4.0+

Xamarin.Android

Xamarin.iOS

Xamarin.Forms

React Native

  • react-native 0.60 (0.63 if using Fast Refresh). Additionally, for a comprehensive understanding of supported React-Native versions, you can consult the official React-Native Releases Support Policy page.

  • Kotlin 1.7.21

  • Swift 4.0+

Titanium

.NET for iOS

.NET for Android