Requirements for Scandit Data Capture SDK 6.2#

Native Platforms#

Platform

Requirements

Android

  • Android 4.4 (API level 19)

  • ARMv7, ARM64, x86, x86_64

  • Camera resolution of 720p or higher is recommended

  • GPU required 1

iOS

  • iOS 9.0 2

  • ARMv7, ARM64, i386, x86_64

  • Camera resolution of 720p or higher is recommended

  • GPU required

1

On Android hardware acceleration has to be enabled for the camera preview to work. Hardware acceleration is enabled by default since API level 14 but can potentially be turned off in the Manifest, do not do this if you use the camera.

2

BarcodeTrackingAdvancedOverlay has a minimum version of iOS 10.0

Framework Platforms#

These platforms are based on the native platform SDKs and therefore the requirements of the native platforms are also relevant here but are not repeated if they do not change. Certain frameworks have stricter restrictions (e.g. they only support newer versions of Android/iOS) and in those cases it is explicitly stated.

Platform

Requirements

Cordova